Use our own Appspot Instance?

@silverton's Avatar

@silverton

23 Apr, 2012 02:13 AM

Can we? How to? Thanks!

  1. Support Staff 1 Posted by Paddy Foran on 23 May, 2012 07:38 PM

    Paddy Foran's Avatar

    Hi Michael!

    You can absolutely use your own appspot instance. You should be able to find instructions in the Github repository: https://github.com/2cloud/AppEngine

    Please do let me know if you need help setting it up. I promise my response time will be quicker than a month, if you do (Sorry! Lost track of this as things got busy at 2cloud HQ).

    Cheers,
    Paddy

  2. 2 Posted by Edgar on 30 May, 2012 06:22 AM

    Edgar's Avatar

    Hi Paddy,

    I tried to install my own appspot instance using the instructions on Github. Deploying etc. is fine but when I visit the newly generated instance I get a

    Traceback (most recent call last):
    File "/base/python_runtime/python_lib/versions/1/google/appengine/ext/webapp/_webapp25.py", line 701, in __call__
        handler.get(*groups)
    File "/base/data/home/apps/s~edgarsphone2chrome/1.359262812008151911/devlinks.py", line 61, in get
        override_quota=user_data.immune())
    File "/base/data/home/apps/s~edgarsphone2chrome/1.359262812008151911/channels.py", line 30, in __init__
        if models.getQuota().amount > models.getStats(
    AttributeError: 'Key' object has no attribute 'amount'
    

    Any idea?

  3. 3 Posted by Edgar on 30 May, 2012 06:30 AM

    Edgar's Avatar

    PS. Sending links doesn't seem to work. From the appspot logs:

    "POST /links/add HTTP/1.1" 200 205 - "Apache-HttpClient/UNAVAILABLE (java 1.4)" "edgarsphone2chrome.appspot.com" ms=39 cpu_ms=0 api_cpu_ms=0 cpm_usd=0.000090 instance=00c61b117cb4ef94456285a9f1986e8217bd14
    

    Thanks,

    Edgar

  4. 4 Posted by Michel on 04 Jun, 2012 02:37 PM

    Michel's Avatar

    Edgar: That is an older issue which is patched in one of the GIT trees I believe. Where did you get your code from?

  5. 5 Posted by Edgar on 04 Jun, 2012 04:13 PM

    Edgar's Avatar

    Michel,

    git clone https://github.com/2cloud/AppEngine.git
    

    Cloned moments before I posted the message above :-).

  6. 6 Posted by Michel on 04 Jun, 2012 05:32 PM

    Michel's Avatar

    OK. I remember debugging this with Paddy and him putting in a fix, but maybe that one's not working. My workaround has always been to remove all references to getQuota from the code (I don't need/use the quota functionality anyway.) so you'll probably have to do that manually.

  7. 7 Posted by Edgar on 05 Jun, 2012 02:55 PM

    Edgar's Avatar

    For some reason the error is gone now (after disabling and re-enabling the webapp)..

    But, in order to actually make it accept links, one does need to visit https://[URL].appspot.com/quota/set and set an appropriate amount of "credits" :-).

    Thanks for your help,

    Edgar

  8. 8 Posted by Karl on 09 Jun, 2012 12:17 AM

    Karl's Avatar

    I'm just trying to set this up today & am getting the exact same error, except disabling & re-enabling the webapp doesn't seem to help...

    Any suggestions would be greatly appreciated! Thanks.

  9. 9 Posted by Karl on 09 Jun, 2012 03:18 AM

    Karl's Avatar

    Update: So after having no success disabling & re-enabling the webapp a few times I tried flushing the cache on the "Memcache Viewer" page & immediately after that it started to work! I did still have to set a quota as mentioned by Edgar though.

    Not sure why that worked but thought I'd report back in case it helps anyone else.

  10. 10 Posted by Michel on 09 Jun, 2012 03:57 PM

    Michel's Avatar

    Having to set a quota is normal. Why the quota routines don't work initially and then suddenly spring into action is anybody's guess. (Maybe even an Appengine bug?)

  11. Support Staff 11 Posted by Paddy Foran on 16 Jun, 2012 10:44 AM

    Paddy Foran's Avatar

    Sorry this is such a pain guys. Version 3 is built to be easy to host, with a much better install experience, so hopefully this should be a non-issue. We're also building in a configuration value to disable billing completely, so things like this aren't an issue.

    We use memcache for all our datastore calls as a way to speed up the app and save money. As such, the bug is most likely that memcache hadn't updated to reflect the new values. Sorry about that.

    Thanks so much for stepping up and helping out with this, Michael. I was drooling blood into a pillow when it came up after having my wisdom teeth removed, so I really appreciate the assistance. :)

    Thanks,
    Paddy

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac