Settings not saving even when going to final page

Leigh Bicknell's Avatar

Leigh Bicknell

13 Mar, 2015 05:58 PM

The settings do not save even when visiting the final settings page (with the qr code) and clicking save/done.

Looking at the settings page, they are all empty.
Each time the browser is restarted the app refuses to function. It has to be removed and reinstalled. Following the settings process again.

I'm not sure if just filling out the settings page would work, as the settings on the page don't correspond to the settings entered when setup. For example, what are 'Key' and 'Secret'? These aren't fields that are filled out during initial setup and as such are confusing. Are they optional? If so some indication that this is the case would help here. 'Host' I can only imagine is the server, but the server in the initial setup has a default in it meaning most users are going to choose that and not forget it. In the settings page there is no default. Making re-entering this field manually another settings based issue for anyone without an eidetic memory.

  1. 1 Posted by Leigh Bicknell on 13 Mar, 2015 06:02 PM

    Leigh Bicknell's Avatar

    Do you have an open source code base such as github?
    I'm not versed in browser plugins, but I have a programming background and this is the kind of issue i'd be happy to look into creating a fix for should I find the opportunity.

  2. Support Staff 2 Posted by Paddy Foran on 14 Mar, 2015 07:59 PM

    Paddy Foran's Avatar

    Hi Leigh!

    Apologies for the delay in the replying.

    I'm pretty sure the settings page is just broken, which is embarrassing, but I haven't had time to look at it lately. :(

    The best way to tell if the settings are saved is if the setup process keeps restarting every time you open the browser. If not, it's got your settings saved.

    The setup for this is horrible, and I apologise profusely for how terrible it is. It brings me shame.

    The code is open source: https://github.com/2cloud/chrome-legacy but it is really, really old and embarrassing. I would happily review and accept any patches, but I suspect your problem lies elsewhere. I am working on getting this project fixed, but it's a long and winding path to do it properly. Perhaps I need to rethink the way I'm managing it.

    In any event, I can probably help you get a more immediate solution to your problem with some extra information. If you visit http://links.2cloudproject.com/chromeconsole it will give you instructions on how to get the console output. If you'd do that for the background page (it says "if links aren't appearing" in bold at the start of the section) I can try to help you get it working as it should.

    Apologies for all the problems you're having. Please let me know how I can assist.

    Hugs,
    Paddy

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac